Gallery CMS
Gallery CMS > .NET CMS online support forum > Issues: Open a ticket! > Report any errors

Parser Error

RSS
Author
Date & Time
Message Operations
Erwin De Wolf
notdefinite
erwindewolf@live.nl
Edewolf

What can I do? Firsttime running gives this error:

Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

Parser Error Message: The file '/MasterPage.master' does not exist.

Source Error:

Line 1: <%@ Page Language="VB" MasterPageFile="~/MasterPage.master" AutoEventWireup="false" EnableViewState="false" Inherits="_Default" CodeFile="default.aspx.vb" %>
Andrea Bruno
male
customercare@officialguide.info
Webmaster

I assume you have not copied properly, the content on your hosting service.Copy the contents of the CMS directory on the root of your web space. You'll see that it works.
Erwin De Wolf
notdefinite
erwindewolf@live.nl
Edewolf

I tryed again, still the same. In the default.aspx is written: "MasterPageFile="~/MasterPage.master" It looks like it's search his MasterPage.master in a directory above, because off ~/
When I delete the ~/ it finds the Masterpage but with the next error: Compiler Error Message: BC30002: Type 'Components.MasterPageEnhanced' is not defined.
What do I wrong?
Andrea Bruno
male
customercare@officialguide.info
Webmaster

I think it's because you have not copied everything in the root but in a sub directory.
When you have copied the contents, you've also copied to the CMS directory? The CMS directory should not be copied, only its contents to be copied!
In local runs correctly?
I suggest, to ask for assistance here: http://forums.iis.net/1045.aspx/1?Publishing (Yours is a configuration problem of the hosting service or IIS).
Let me know if you have solved. Which version of CMS do you use? Where are you installing? Locally? In a server? In a share hosting service?
Erwin De Wolf
notdefinite
erwindewolf@live.nl
Edewolf

Problem solved. I published the hole cms directory to a extern server. That's wrong. It works fine/excellent in the direct-root. I placed it in a sub-directory, because I want to test/build it beside the formal website. Can I change the name of the default.aspx into start.aspx for example? What I want to reach is a test/build enviroment in a share hosting server.